Since a few months I have the common practice to directly map closures to a function. It cleans up the code a bit, and moves the actual functionality to somewhere else in your code.

Instead of doing: